Question: What is my potential all over the place?

Greg_H is asking a question about question: Subscribe to answer questions on this topic

Greg_H asked on December 21, 2017 09:05
219 | 2 answers | shortlink


I have a problem with the WheeStat that I bought. The potential that is read by the software is very different from the one that I apply. Do you have an idea of what I am doing wrong?
Does it have to do with which power source is being selected? Debug or Device? On the website picture, it shows that the microcontroller is powered up via the debug. Is this correct?



wheestat

question:question question:wheestat



6 Comments

stevie 4 months ago

I'm sorry you're having trouble. Pinging in @JSummers to see if he has any ideas on how to help!

Greg_H 4 months ago

Thanks. That would be great!

JSummers 4 months ago

Hi @Greg_H, sorry you are having trouble. The microcontroller should be powered up, and it must be if you are getting any kind of readout at all. What are the leads (alligator clips) attached to? If you connect the black lead to one side of a resistor (10 Kohm works well) and the other two leads to the other side of the resistor, you should get a straight line correlating voltage and current. If you dont have the leads attached to anything, you will not get anything reasonable back. Let me know how this works. Jack

Greg_H 4 months ago

Thank you @JSummers, the microcontroller is linked to my computer via the USB lead on the debug plug. I am having potential reading on my GUI but it is closer to 1.5 V than to the 0.4 V applied. I was using a 1 MOhm resistor so the current might too low to have a correct reading. I will try with a 10 kOhm as soon as i am back to work. I will let you know how I am getting on. Thank you for help.

Greg_H 3 months ago

@JSummers, I have tried with a 10 kOhms, but there is no improvement. The potential is still not being scanned properly. The leads are properly connected. I can't see what I am doing wrong. Does the potential need to be calibrated?

Greg_H 3 months ago

Is it possible that I am using the wrong software. It says WheeStat 5 on my potentiostat chip. Which software should I be using?

Log in to comment

2 Answers

Hi @Greg_H, I am sorry that you are still having trouble with your WheeStat.
While it is possible that it is a software problem, it seems more likely that the hardware is at issue. One thing that happens with some frequency is that the solder connection to one of the alligator clips comes loose. Before you do anything else, I would check this by measuring the resistance between each of the alligator clips and the connection on the circuit board. Even if it seems OK, I recommend re-melting the solder to each of the clips and re-running the experiment. There are two kinds of software used, the GUI software and the microcontroller firmware. The GUI software is the same for the two versions of the WheeStat that are avialable. The microcontroller should have been flashed with the correct software before it was sent to you. You should have a usb drive with the source code on it. The firmware for the 5 series instrument is called WheeStat6_c or WheeStat6_d (the latter is the more recent). To re-flash the firmware, download Energia from energia.nu and open the WheeStat6 file in Energia. You will need to create a folder called "libraries" in your Energia sketchbook folder and put the "altSPI" folder in there. From the Energia IDE, go to Tools>Boards and open the boards manager window. You will need to select the Tiva C board from the list.
Once you have done this, you should be able to load the software onto the microcontroller by clicking on the play button on the upper left of the IDE. Let me know what happens with re-soldering the leads. If you decide to re-flash the microcontroller, let me know if you get stuck and I will help you out. Jack


raju1002 3 months ago

http://august2018calendar.info

http://march2018calendar.info/

http://may2018calendar.info/ http://upstrack.info/ http://faxcoversheet.info/ http://usabankroutingnumber.com http://heartemoji.co/ http://allencooperenterprises.com/ http://highbloodpressure.me/
http://periodictable.me http://allcustomerservicenumbers.com/

Log in to comment

Hi @JSummers, We have checked the connections and they seem fine. I downloaded Energia. Tiva C card was selected on the board list, but we run into this error message : Energia: 1.6.10E18 (Windows 7), Carte : "LaunchPad (Tiva C) w/ tm4c123 (80MHz)"

C:\Users\herzog\Documents\Nancy-CNRS\Collaboration\Yusri Yusup USM\Wheestat\MicrocontrollerSourceCode\WheeStat6_c\WheeStat6_c.ino:19:101: fatal error: altSPI.h: No such file or directory

#include <altSPI.h> // alternative SPI library must be in "libraries" folder in sketchbook

                                                                                              ^

compilation terminated.

exit status 1 Compialtion error for card LaunchPad (Tiva C) w/ tm4c123 (80MHz)

Where is the altSPI.h file?

Thanks for your help!


JSummers 3 months ago

Hi @Greg_H, If the altSPI files are not on your usb memory you can download them here: https://github.com/SmokyMountainScientific/altSPI There should be a file with the .h extension and one with .cpp. They both need to go in a folder called altSPI inside a folder called libraries which needs to be in your energia sketch folder.
If this does not work, contact me at summers at wcu dot edu and we can figure out how to get a new board to you. Best, Jack

Log in to comment

Sign up or Login to post an answer to this question.